My Oracle Support Banner

Deploying a Portal from one Environment to Another Causes the Skin Color to be Lost (Doc ID 2494062.1)

Last updated on JULY 10, 2019

Applies to:

Oracle WebCenter Portal - Version 12.2.1.0.0 to 12.2.1.3.0
Information in this document applies to any platform.

Symptoms


ACTUAL BEHAVIOR

Deploying a Portal from one environment to another causes the Skin color to be lost.


EXPECTED BEHAVIOR

Expect Skin to show the correct colors in the deployed portal.


STEPS

The issue can be reproduced at will with the following steps:

  1. Create a Portal.

  2. Add an HTML component in the Home page in the portal.

  3. Go to the Portal Assets -> Skins.

  4. Copy the Alta skin.

  5. Edit the copied skin and add the following at the end of the file:

    .af_showDetailFrame_content
       {
         background-color:lightblue !important;
       }


  6. Go to the Portal Settings.

  7. Set the following settings and click Save:

    Page Template: Alta Top Navigation
    Skin: Copy of Alta Skin

  8. View the portal.
    You should see the HTML component shows a blue background.

  9. Go to Administer the portal.

  10. Deploy the portal to a target environment.

  11. View the portal in the target environment.
    You will see the HTML component doesn't have the blue background.

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.