My Oracle Support Banner

ODSEE 11.1.1.7.190716 Bundle Patch Has Been Released for Directory Server and Directory Proxy Server (Doc ID 2565061.1)

Last updated on AUGUST 16, 2019

Applies to:

Oracle Directory Server Enterprise Edition - Version 11.1.1.7.0 and later
Linux x86-64
Oracle Solaris on SPARC (64-bit)
Oracle Solaris on x86-64 (64-bit)

Details

As detailed in KM_Doc_ID_1373397.1, the ODSEE product releases follow the new patch delivery process.

The 11.1.1.7.181016 Bundle Patch for ODSEE covering both Directory Server and Directory Proxy is now available through the Oracle patch portal.

This Bundle Patch is provided for existing ODSEE 11.1.1.7.0, 11.1.1.7.1, 11.1.1.7.2, 11.1.1.7.3, 11.1.1.7.160719, 11.1.1.7.170418, 11.1.1.7.170718, 11.1.1.7.171017, and 11.1.1.7.181016 deployments.

Customers are strongly encouraged to install the 11.1.1.7.181016 Bundle Patch for ODSEE.

In order to install this Bundle Patch, the existing deployment must be running version 11.1.1.7.0, 11.1.1.7.1, 11.1.1.7.2, 11.1.1.7.3, 11.1.1.7.160719, 11.1.1.7.170418, 11.1.1.7.170718, 11.1.1.7.171017, 11.1.1.7.181016. Customers running earlier versions of ODSEE 11g are encouraged to upgrade to 11.1.1.7.0.

The 11.1.1.7.190716 Bundle Patch Release Notes are available within the patch in the readme.html file.

Some preventative actions to take prior to installing the 11.1.1.7.190716 Bundle Patch (with more details in the Release Notes)

Requirements: Verify: Additional Info:
1) Check current version Current version must be 11.1.1.7.0, 11.1.1.7.1, 11.1.1.7.2, 11.1.1.7.3, 11.1.1.7.160719, 11.1.1.7.170418, 11.1.1.7.170718, 11.1.1.7.171017, or 11.1.1.7.181016 Run `dsadm --version`
2) Backup existing 11.1.1.7.x Backup has been performed Make sure to stop the server instances and the DSCC agent before backing up the instances.
3) Install patch with appropriate credentials ODSEE owner

Applying the bundle patch can be performed only by the user account that owns the Directory Server Enterprise Edition installation.

The ODSEE owner can be identified by -

- For Directory Server - Checking the value of nsslapd-localuser in -

<DSInstancePath>/config/dse.ldif

- For Directory Proxy Server - Checking the value of username in -

<DPSInstancePath>/config/state

 

- OR -

By running -

-- For Directory Server -

dsadm info <path to instance> | grep -i owner

-- For Directory Proxy Server -

dpadm info <path to instance> | grep -i owner

 

See the patch README for full details.

Oracle recommends thorough testing in a pre-production environment prior to applying this bundle patch in production.

Actions

 

Current Version: Recommended Action: Then Install:
ODSEE7 Upgrade to 11.1.1.7.0 11.1.1.7.181016
ODSEE 11.1.1.3.0 Upgrade to 11.1.1.7.0 11.1.1.7.181016
ODSEE 11.1.1.5.x Upgrade to 11.1.1.7.0 11.1.1.7.181016
ODSEE 11.1.1.7.0, 11.1.1.7.1, 11.1.1.7.2, 11.1.1.7.3, 11.1.1.7.160719, 11.1.1.7.170418, 11.1.1.7.170718, 11.1.1.7.171017, or 11.1.1.7.181016 Apply patch 29893742  

 

The following tables provides the information on which patches are required to download based on the OS. All platforms now use the Compressed Archive (ZIP) Distribution.

 

OS Release: Patch Number:
Linux x86-64 (64-bit)
<Patch: 29893742>
Solaris on SPARC (64 Bit) <Patch: 29893742>
Solaris on x86-64 (64 Bit) <Patch: 29893742>
Microsoft Windows x64 (64-bit) <Patch: 29893742>
Take Note of -
ODSEE Windows - After Applying Bundle Patch When Running dsconf.exe - Exception in thread "main" java.lang.NoClassDefFoundError: javax/net/ssl/SSLHandshakeException (Doc ID 2577695.1)

 


 


 

The 11.1.1.7.190716 Bundle Patch release notes are available within the patch in the readme.html file.

 

Contacts

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Details
Actions
Contacts
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.