My Oracle Support Banner

Exalogic Virtual 2.0.6.3.X: Cnode Script (cnode-vserver-control.py) Fails With “SSHException: Incompatible ssh server (no acceptable ciphers)” Error (Doc ID 2616117.1)

Last updated on DECEMBER 05, 2019

Applies to:

Oracle Exalogic Elastic Cloud Software - Version 2.0.6.3.0 and later
Linux x86-64
Oracle Virtual Server x86-64

Symptoms

In Exalogic Virtual racks 2.0.6.3.X, issue of cnode script (cnode-vserver-control.py) failing with “SSHException: Incompatible ssh server (no acceptable ciphers)” error is noticed. Following is the error message printed on the console during cnode script execution failure.

Above failure with cnode script is not seen if we are using cnode script purely locally within the compute node (without SSH’ing into other Compute nodes) and doing actions such as saving list of running VMs, stopping and starting VMs (actions mentioned in <Note 2567412.1>). But if any advanced actions are done using cnode script from like connecting from Compute Node (similar to running DCLI from Compute Node) to other Compute Nodes via SSH for saving list of VMs, stopping/starting, then we will encounter the issue mentioned in this Note. Basically any advanced actions which are mentioned in section 2.1.X in <Note 1945615.1> will cause the code script to fail.

Changes

Applying Patch 30513296.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.