My Oracle Support Banner

"ORA-01031: insufficient privileges" Upgrading to ODI 12.2.1.4 with the Upgrade Assistant (Doc ID 2655060.1)

Last updated on APRIL 12, 2021

Applies to:

Oracle Data Integrator - Version 12.2.1.4.0 and later
Information in this document applies to any platform.

Symptoms

During the upgrade to Oracle Data Integrator 12.2.1.4, the Upgrade Assistant fails with the following error reported in the log:

[2020-03-27T10:08:27.287-07:00] [odi] [ERROR] [ODI-14064] [oracle.odi.setup] Error while applying DDL from file <ORACLE_HOME>/odi/sdk/lib/scripts/ORACLE/patches/M_05.01.01.03_05.01.01.04.xml
[2020-03-27T10:08:27.287-07:00] [odi] [ERROR] [ODI-14096] [oracle.odi.setup] Error While Upgrading Master Repository Error while executing DDL Patch M_05.01.01.03_05.01.01.04.xml
[2020-03-27T10:08:27.294-07:00] [ODI] [INCIDENT_ERROR] [ODIUPG-00008] [upgrade.ODI.ODI1] Unknown error happened.
[2020-03-27T10:08:27.294-07:00] [ODI] [INCIDENT_ERROR] [] [upgrade.ODI.ODI1] Cause: Unknown error happened.
[2020-03-27T10:08:27.294-07:00] [ODI] [INCIDENT_ERROR] [] [upgrade.ODI.ODI1] Action: Restore Master Repository from Backup and try to upgrade again.
[2020-03-27T10:08:27.295-07:00] [ODI] [INCIDENT_ERROR] [] [upgrade.ODI.ODI1] [[
oracle.odi.setup.RepositorySetupException: com.sunopsis.repository.manager.upgrade.RepositoryUpgradeException: Error while executing DDL Patch M_05.01.01.03_05.01.01.04.xml
  at oracle.odi.setup.support.MasterRepositorySetupImpl.upgradeMasterRepository(MasterRepositorySetupImpl.java:810)
  at oracle.odi.setup.support.MasterRepositorySetupImpl.upgradeMasterRepository(MasterRepositorySetupImpl.java:700)
  at oracle.odi.setup.support.MasterRepositorySetupImpl.upgradeMasterRepository(MasterRepositorySetupImpl.java:881)
  at oracle.odi.setup.RepositoryUpgradeServiceImpl.upgradeRepositories(RepositoryUpgradeServiceImpl.java:423)
  ...
Caused by: com.sunopsis.repository.manager.upgrade.RepositoryUpgradeException: Error while executing DDL Patch M_05.01.01.03_05.01.01.04.xml
  at com.sunopsis.repository.manager.upgrade.AbstractRepositoryUpgrade.executeUpgradeDDL(AbstractRepositoryUpgrade.java:157)
  at com.sunopsis.repository.manager.upgrade.AbstractRepositoryUpgrade.upgradeMasterRepository(AbstractRepositoryUpgrade.java:280)
  at com.sunopsis.repository.manager.upgrade.RepositoryUpgradeRunner.upgradeMasterRepository(RepositoryUpgradeRunner.java:482)
  at com.sunopsis.repository.manager.RepositoryManager.masterRepositoryPatch(RepositoryManager.java:4922)
  ...
Caused by: java.lang.RuntimeException: Error while executing create table SNP_ENT_PRINCIPAL
(
  ...
)
  at com.sunopsis.dwg.xml.DwgXmlSession.execute(DwgXmlSession.java:101)
  at com.sunopsis.repository.manager.DDLSessionExecutor.executeDDL(DDLSessionExecutor.java:124)
  at com.sunopsis.repository.manager.upgrade.AbstractRepositoryUpgrade.executeUpgradeDDL(AbstractRepositoryUpgrade.java:155)
  ... 16 more
Caused by: java.sql.SQLSyntaxErrorException: ORA-01031: insufficient privileges
  at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:510)
  at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:462)
  at oracle.jdbc.driver.T4C8Oall.processError(T4C8Oall.java:1105)
  at oracle.jdbc.driver.T4CTTIfun.receive(T4CTTIfun.java:551)
  at oracle.jdbc.driver.T4CTTIfun.doRPC(T4CTTIfun.java:269)
  at oracle.jdbc.driver.T4C8Oall.doOALL(T4C8Oall.java:656)
  at oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:271)
  ...
Caused by: Error : 1031, Position : 0, Sql = create table SNP_ENT_PRINCIPAL ( ... ),

Error Msg = ORA-01031: insufficient privileges
  at oracle.jdbc.driver.T4CTTIoer11.processError(T4CTTIoer11.java:514)
  ...

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.