My Oracle Support Banner

Installation Failure During Upgrade from OID 12.2.1.3 to OID 12.2.1.4 "INST-07545: Unexpected Error" "The distribution Oracle Fusion Middleware 12c Infrastructure 12.2.1.4.0 contains incompatible features" (Doc ID 2672275.1)

Last updated on MAY 20, 2020

Applies to:

Oracle Internet Directory - Version 12.2.1.3.0 and later
Oracle Fusion Middleware - Version 12.2.1.3.0 and later
Information in this document applies to any platform.

Symptoms

 Upgrading OID 12.2.1.3 to OID 12.2.1.4
3 Upgrading Oracle Internet Directory Single Node 12c Environments

1.Stop all services (OID and WLS components)
2. Uninstall using deinstall.sh (on Unix)
3. Install  Infrastructure

Oracle Fusion Middleware Infrastructure:
(UNIX) JDK_HOME/bin/java -jar fmw_12.2.1.4.0_infrastructure.jar
(Windows) JDK_HOME\bin\java -jar fmw_12.2.1.4.0_infrastructure.jar

Results with the following error during installation:


INST-07545: Unexpected Error. The distribution Oracle Fusion Middleware 12c Infrastructure 12.2.1.4.0 contains incompatible features with the following:
Oracle Fusion Middleware 12c Infrastructure 12.2.1.3.0 [CIE WLS Shared External 12.2.1.4.0->CIE WLS Shared External 12.2.1.3.0 (oracle.fmwconfig.wls.shared 12.2.1.4.0->[oracle.fmwconfig.wls.shared 12.2.1.3.0], oracle.fmwconfig.common.wls.shared.external 12.2.1.4.0->[oracle.fmwconfig.common.wls.shared.external 12.2.1.3.0])]
Oracle Fusion Middleware 12c Infrastructure 12.2.1.3.0 [CIE WLS External 12.2.1.4.0->CIE WLS External 12.2.1.3.0 (oracle.fmwconfig.common.wls.external 12.2.1.4.0->[oracle.fmwconfig.common.wls.external 12.2.1.3.0])]
Oracle Fusion Middleware 12c Infrastructure 12.2.1.3.0 [Oracle Globalization Support Files For ORAMAPPING 19.3.0.0.0->Oracle Globalization Support Files For ORAMAPPING 12.2.0.1.0 (oracle.nlsoramapping.jrf 19.3.0.0.0->[oracle.nlsoramapping.jrf 12.2.0.1.0])]
Oracle Fusion Middleware 12c Infrastructure 12.2.1.3.0 [Oracle Globalization Support Files 19.3.0.0.0->Oracle Globalization Support Files 12.2.0.1.0 (oracle.nlsrtl.jrf 19.3.0.0.0->[oracle.nlsrtl.jrf 12.2.0.1.0])]
Oracle Fusion Middleware 12c Infrastructure 12.2.1.3.0 [Oracle JRF JAXP XML Development Kit 12.2.1.4.0->Oracle JRF JAXP XML Development Kit 12.2.1.3.0 (oracle.xdk.jrf.jaxp 12.2.1.4.0->[oracle.xdk.jrf.jaxp 12.2.1.3.0])]
SNIP-IT
Oracle Fusion Middleware 12c Infrastructure 12.2.1.3.0 [Properties Loader 12.2.1.4.0->Properties Loader 12.2.1.3.0 (oracle.as.customqna.jdkqna 12.2.1.4.0->[oracle.as.customqna.jdkqna 12.2.1.3.0])]
Oracle Fusion Middleware 12c Infrastructure 12.2.1.3.0 [WebLogic Client Jars 12.2.1.4.0->WebLogic Client Jars 12.2.1.3.0 (oracle.wls.clients 12.2.1.4.0->[oracle.wls.clients 12.2.1.3.0])]

Changes

 Upgrade

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.