My Oracle Support Banner

Exchange Connector Certified To Use OnPremise2019 as ExchangeServerType (Doc ID 2802757.1)

Last updated on OCTOBER 07, 2021

Applies to:

Identity Manager Connector - Version 11.1.1.6.0 and later
Information in this document applies to any platform.

Symptoms

This document (https://docs.oracle.com/cd/E22999_01/doc.111/e27258/microsoft-exchange-connector.htm#CGMEX129) says Exchange version 2019 is supported however when updated "ExchangeServerType" to "OnPremise2019" in IT Resource then it is throwing error.

ConnectorServer.exe Error 0 Invalid server type text: OnPremise2019 2021-04-18 07:04:51Z
ConnectorServer.exe Error 0 Index (zero based) must be greater than or equal to zero and less than the size of the argument list.
 at Org.IdentityConnectors.Framework.Impl.Api.Remote.Messages.OperationResponsePart ProcessOperationRequest(Org.IdentityConnectors.Framework.Impl.Api.Remote.Messages.OperationRequest) in Server.cs:604
2021-04-18 07:04:51Z

It is working fine with OnPremise2016 or OnPremise2013 values.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.