My Oracle Support Banner

Downgrade Of Apex 21.2 To Lower versions is getting failed (Doc ID 2846875.1)

Last updated on FEBRUARY 03, 2022

Applies to:

Oracle Application Express (APEX) - Version 21.2 and later
Information in this document applies to any platform.

Symptoms

Upgraded from APEX 5.1.x to APEX 21.2

For testing purposes, trying attempt to downgrade as part of testing rollback strategy for the proposed upgrade
Following the below document
https://docs.oracle.com/en/database/oracle/application-express/21.2/htmig/reverting-to-a-previous-release.html#GUID-F85C84B1-37B6-4C40-95E5-712640899467

While downgrading it failed with the below Error


ERROR
-----------------------
ORA-39705: component 'APEX' not found in registry
ORA-06512: at "SYS.DBMS_SYS_ERROR", line 86
ORA-06512: at "SYS.DBMS_REGISTRY", line 353
ORA-06512: at "SYS.DBMS_REGISTRY", line 384
ORA-06512: at "SYS.VALIDATE_APEX", line 343
ORA-06512: at line 1


Changes

 Trying to downgrade from APEX 21.2

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.