My Oracle Support Banner

Upgrading 19c JDBC Driver Conflicts With Custom Application XML Parser Functionalities (Doc ID 2934351.1)

Last updated on MARCH 14, 2023

Applies to:

Oracle WebLogic Server - Version 12.2.1.4.0 and later
Information in this document applies to any platform.

Goal

In Oracle FMW Infrastructure 12.2.1.4, after upgrading JDBC drivers to 19c as per the following Oracle documentation, some J2EE applications which are using other XML parsers implementations are throwing errors because of the change of the XML parser.

Upgrading and Using Latest Oracle 19c JDBC Drivers with WebLogic Server

https://docs.oracle.com/en/middleware/fusion-middleware/weblogic-server/12.2.1.4/jdbca/configure-database-connectivity.html#GUID-2DA777A9-FB2E-41A2-A2FD-06CE66C7DB11,


Using ojdbc8-full/xmlparserv2_sans_jaxp_services.jar broke the application features related to XML parser.
After removing the library "xmlparserv2_sans_jaxp_services.jar" and the JDBC Driver 19c works fine with WLS default parser.

Is it mandatory to configure the parser "ojdbc8-full/xmlparserv2_sans_jaxp_services.jar" in the PRE_CLASSPATH or can it removed ?

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
 Upgrading and Using Latest Oracle 19c JDBC Drivers with WebLogic Server
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.