My Oracle Support Banner

Application Fails with Error "No persistence unit named 'PU01_NAME' is available in scope EJB.jar. Available persistence units: [PU02_NAME]" (Doc ID 2942301.1)

Last updated on APRIL 15, 2024

Applies to:

Oracle WebLogic Server - Version 12.2.1.0.0 and later
Information in this document applies to any platform.

Symptoms

WebLogic is migrated from 12.1.3 to 14.1.1. After the migration, an EAR application fails with the following error:

The application EAR file contains two EJB JAR files. Each EJB JAR has a persistences.xml with a Persistence Unit (PU) defined. The error occurs when an EJB from the first EJB module invokes an EJB from the second EJB module that references the Persistence Unit from the first module.

Changes

Upgrade from WebLogic 12.1.3 to 14.1.1 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.