My Oracle Support Banner

ODI Fails to Connect to Oracle Database Version 19.22 Using Orapki Wallet (Doc ID 3007192.1)

Last updated on MARCH 15, 2024

Applies to:

Oracle Data Integrator - Version 12.2.1.4.231215 to 12.2.1.4.231215 [Release 12c]
Oracle Data Integrator on Marketplace - Version 12.2.1.4.231215 to 12.2.1.4.231215
Information in this document applies to any platform.

Symptoms

After having applied Oracle Database (DB / RDBMS) to Oracle DB 19.22 version (January 2024 CPU), Oracle Data Integrator (ODI) 12c is unable to use the wallet created by the orapki utility to connect to the database.

Attempting to open an auto login wallet prompts for a password and then fails with the following error:


The issue doesn't occur with previous RDBMS versions, i.e. version 19.21 and below.

Changes

 Oracle DB 19.21 was upgraded to Oracle DB 19.22.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.