My Oracle Support Banner

RP/TUX 7.1, TUX 8.0 - 3 Domains, WLS/WTC1.1 - TUX71 System Hangs When "tpacall" is made recursively. (Doc ID 768398.1)

Last updated on MAY 19, 2020

Applies to:

Oracle Tuxedo - Version 7.1 and later
Information in this document applies to any platform.
Information in this document applies to any platform
***Checked for relevance on 13-07-2011***


Goal

Scenario: 3 domains WLS(WTC1.1) load 9(SOL) - TUX71(AIX) - TUX71(HP)

WHEN "tpacall" is done repeatedly .. WTC(1.1) recieves new connection each time. Tux 7.1 ULOG reports
dropping old connection.... The Servers on both side hang at the point forever.
------------------------------------------------------------------------------
TUX71(HP) ULOG OUTPUT
161727.TuxMachine1!WSL.xx.1.0: LIBTUX_CAT:262: INFO: Standard main starting
162007.TuxMachine1!GWTDOMAIN.xxx.1.0: LIBGWT_CAT:1129: INFO: Connection established with domain (domainid=<Domain3Name>)
162008.TuxMachine1!GWTDOMAIN.xxx.1.0: INFO: New connection to remote domain (Domain3Name) accepted, drop old connection!
162009.TuxMachine1!GWTDOMAIN.xxx.1.0: INFO: New connection to remote domain (Domain3Name) accepted, drop old connection!
162009.TuxMachine1!GWTDOMAIN.xxx.1.0: INFO: New connection to remote domain (Domain3Name) accepted, drop old connection!
162010.TuxMachine1!GWTDOMAIN.xxx.1.0: INFO: New connection to remote domain (Domain3Name) accepted, drop old connection!
162010.TuxMachine1!GWTDOMAIN.xxx.1.0: INFO: New connection to remote domain (Domain3Name) accepted, drop old connection!
162010.TuxMachine1!GWTDOMAIN.xxx.1.0: INFO: New connection to remote domain (Domain3Name) accepted, drop old connection!

TUX71 (AIX) ULOG OUTPUT
161711.TuxMachine2!twodomserv.xxx.1.0: Welcome to the 3DOMIANS SERVER I
161712.TuxMachine2!WSL.xxx.1.0: 07-09-2001: Tuxedo Version 7.1 
161712.TuxMachine2!WSL.xxx.1.0: LIBTUX_CAT:262: INFO: Standard main starting
162010.TuxMachine2!GWTDOMAIN.xxx.1.0: LIBGWT_CAT:1129: INFO: Connection established with domain
(domainid=<Domain3Name>)
162011.TuxMachine2!GWTDOMAIN.xxx.1.0: INFO: New connection to remote domain (Domain3Name) accepted, drop old connection!
162013.TuxMachine2!twodomserv.xxx.1.0: ---- Service S1 called! ----
162013.TuxMachine2!twodomserv.xxx.1.0:  S1: Data Received <Domain1Name>entry0

WLS(WTC 1.1) LOAD 9 (SOLARIS) CONSOLE OUTPUT
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/WTCStartup/getRemoteTDomain/<Domain1Name>>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/Utilities/acceptEncryptionFlags/>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/Utilities/getInstalledEncryption/>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/dsession(7)/setRemoteDomainId/<Domain1Name>>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <]/dsession(7)/setRemoteDomainId/10>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/dsession(7)/set_local_domain_name/Domain3Name>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <]/dsession(7)/set_local_domain_name/10>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/dsession(7)/get_sess_sec/>
<Jul 9, 2001 4:20:10 PM EDT> <Info> <WTC> <Accepted Connection from remote domain <Domain1Name>>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <]/gwdsession/do_accept/1000/success/weblogic.wtc.gwt.TDM RemoteTDomain@6d86c3ed>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <]/dsession/tpinit/30/weblogic.wtc.gwt.TDMRemoteTDomain@6d86c3ed>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/WLSInvoke/setRemoteDomain/weblogic.wtc.gwt.TDMRemoteTDomain@6d86c3ed>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> </rdsession7)/dispatch/TdomTcb=TDOM:GWNW_XATMI_CALL:0:-1:0:0:0:0:1966080000:15174:21102622:0:EJBTUXCALLBACK>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <]/rdsession(7)/dispatch/40/>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <]/TuxedoMuxableSocket/dispatch/30/>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/TPServiceRequest/execute/>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> </servicethr/calling invoker/null:0:null:EJBTUXCALLBACK:<Domain1Name>entry0:0:7:-1:weblogic.wtc.jatmi.tfmh@50c800:weblogic.wtc.jatmi.dreqid@7a9fa7>
<Jul 9, 2001 4:20:10 PM EDT> <Debug> <WTC> <[/WLSInvoke/invoke/>
<Jul 9, 2001 4:20:11 PM EDT> <Debug> <WTC><]/TDMRemoteTDomain/getTsession/10/weblogic.wtc.gwt.gwdsession@7>
<Jul 9, 2001 4:20:11 PM EDT> <Debug> <WTC> <*]/gwdsession/do_accept/60/>
<Jul 9, 2001 4:20:11 PM EDT> <Debug> <WTC> </WTCStartup/OatmialListener/run/30/TPEPROTO(9):0:0:TPED_MINVAL(0):QMNONE(0):0:Got a connection from a remote domain that I am already connected to: <Domain1Name>>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> </rdsession(0)/dispatch/TdomTcb=TDOM:GWNW_XATMI_CALL:15:-1:0:0:0:0:1966080000:24950:90125:0:EJBTUXCALLBACK>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <[/TPServiceRequest/execute/>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> </servicethr/calling invoker/null:0:null:EJBTUXCALLBACK:<Domain2Name>entry8:0:0:-1:weblogic.wtc.jatmi.tfmh@7de0d5:weblogic.wtc.jatmi.dreqid@41c9dc>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <[/WLSInvoke/invoke/>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <[/InboundEJBRequest/execute/Thread[ExecuteThread: '9' for queue: 'default',5,Thread Group for Queue: 'default']>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> </InboundEJBRequest/execute/looking up MultiDomainsSvcHome>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/WLSInvoke/invoke/30/>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> </servicethr/invoker success/null:0:null:EJBTUXCALLBACK:<Domain2Name>entry8:0:0:-1:weblogic.wtc.jatmi.tfmh@7de0d5:weblogic.wtc.jatmi.dreqid@41c9dc>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/TPServiceRequest/20/Success>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/rdsession(0)/dispatch/40/>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/TuxedoMuxableSocket/dispatch/30/>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/TpeIn/readTuxedoMessage/120/true>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/TpeIn/readTuxedoMessage/150/true>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> </tfmh/read_dom_65_tfmh/opcode=GWNW_XATMI_PRE_NW_ACALL1>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <[/TpeIn/available/>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/TpeIn/available/20/508>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> </read_dom_65_tfmh/bufsize=540 available=508>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <[/TdomTcb/set_tm_release 70>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/TdomTcb/set_tm_release>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <[/TdomTcb/set_dom_protocol 15>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/TdomTcb/set_dom_protocol>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/read_dom_65_tfmh/70/0/0>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <[/TDMRemoteTDomain/getTsession/false>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <]/TDMRemoteTDomain/getTsession/10/weblogic.wtc.gwt.gwdsession@0>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> <*]/gwdsession/do_accept/60/>
<Jul 9, 2001 4:20:08 PM EDT> <Debug> <WTC> </WTCStartup/OatmialListener/run/30/TPEPROTO(9):0:0:TPED_MINVAL(0):QMNONE(0):0:Got a connection from a remote domain that I am already connected to: <Domain2Name>>

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.