My Oracle Support Banner

Site security does not work for newly added site (Doc ID 2102506.1)

Last updated on AUGUST 14, 2017

Applies to:

Oracle Argus Safety - Version 7.0.6 and later
Information in this document applies to any platform.

Symptoms

The new site has been added.

When opening the user configuration (with the site security enabled is ON), "No access" is selected for the newly added site.

However, the site security does not work so the user can open the case from this site even though the privilege is "No access"

 

-------------
Steps:
-------------
1. Navigate to Argus Console > Access management > Argus > Sites
2. Add the site "SITE001"
3. Save the configuration

4. Navigate to Argus Console > Access management > Argus > Users

5. View the setting of user(A)

Site "SITE001" displays in "Enable Site Security" section with "No Access" privilege.
 

6. View the setting of user(B)
7. Set the site: SITE001 for the user(B)

  
8. Save the configuration.
9. Log-out


10. Log in to Argus as user(B)

11. Go to case action > new in order to create a new case with site:SITE001
12. Book-in
13. Log-out

14. Login to Argus as user(A)
15. Open the created new case in step 11-12 which has the site:SITE001.

The case was displayed without any error even though site "SITE001" has a "No Access" privilege for user(A)

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.