Issue While Running GetOrder XMLAPI Through XQuery Automation In Coherence Cluster ENV (Doc ID 2173901.1)

Last updated on SEPTEMBER 01, 2016

Applies to:

Oracle Communications Order and Service Management - Version 7.3.1.0.0 and later
Information in this document applies to any platform.

Symptoms

There are 2 Managed Servers and this issue we are facing with both servers being online.
The scenario is that the logs for automation is running in Server 2. In the automation, it is trying to do getOrder XMLAPI using XQuery for old order and below errors are being thrown in logs.
Now, if we shutdown Server 1 and then re-execute the automation, it is successfully doing getOrder() and the automation task is completing.


<****** XQUERY AUTO ==> Order ID : 413029 1413048 (MPLS 6.1.0.0.0), Task : getOrderDataModify ******>
Unknown response type from cluster member: [Lcom.tangosol.net.Member;@6adeed1c
Request [ORDER_ID : 1413048, USER_ID : oms-automation, ORDER_VIEW_MNEMONIC : MPLS_View_Task, REQUEST_NAME : com.mslv.oms.handler.getorder.GetOrderHandlerEJB, ACCEPT : false, CLIENT_TYPE : 0, RESPONSE_SOURCE_CLASS : javax.xml.transform.sax.SAXSource, DO_NOT_REFORWARD_REQUEST : true]
oracle.communications.ordermanagement.util.coherence.InvocableResult>
413029309getOrderDataModifyMPLS_Modify_OrderMPLS_Modify_Orderopen.running.in_progressaccepteddo P1D<Expecte

Changes

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms