How to Meet Security Requirements Regarding OpenSSL

(Doc ID 2204894.1)

Last updated on NOVEMBER 21, 2016

Applies to:

Oracle Communications Network Charging and Control - Version 5.0.3 and later
Information in this document applies to any platform.

Goal

To meet the latest security requirements regarding OpenSSL, an upgrade to version 1.0.1s or later may be desired.
Solaris 11.2 and 11.3 are still using OpenSSL 1.0.1.o.

The purpose of this document is to clarify what is the latest version of OpenSSL supported by OCNCC(Oracle Communication Network Charging and Control) and if there are any concerns in case of an upgrade.
To achieve this, the following questions need to be answered:

    1. Is it recommended to upgrade to a later version of OpenSSL?

    2. Nova Installation Guide for OCNCC 5.0.3 states that it's certified only for Solaris 11.2, if an upgrade to Solaris version 11.3 is required, does this pose any issue to OCNCC 5.0.3?

Solution

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms