AutoVue for Agile 21.0.1 (JNLP) Not Working Behind Proxy Server Using SSL (Doc ID 2262454.1)

Last updated on AUGUST 18, 2017

Applies to:

Oracle Autovue for Agile Product Lifecycle Management - Version 21.0.1 and later
Information in this document applies to any platform.

Symptoms

Installed Agile 9.3.6 with AutoVue for Agile 21.0.1. System worked as expected (AutoVue launches and can open attachments when requested). Then enabled a reverse proxy server with SSL offloading at the proxy and now everything (Agile and File manager operations) works, except that AutoVue does not load.

When clicking a file name from the Attachments tab of an item in Agile, there is a prompt with a Java message that asks "Do you want to run this application?" and identifies Oracle AutoVue as the application name with the proxied URL under Locations. When clicking Run, there is an "AutoVue Launcher" popup that says "AutoVue is waiting for a browser connection" and a "Exit and Close AutoVue" button. But nothing more happens. After a couple minutes, there is an error in Agile that reads "The AutoVue client did not start successfully. Please ensure that the server is running and the generated JNLP is launched. You can contact the system administrator for extending the delay required before assuming the AutoVue startup failure."

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms