My Oracle Support Banner

UIM 7.4.1.0.0 And DS 7.4.1 - Compatibility Components And Versions (Doc ID 2678609.1)

Last updated on JUNE 18, 2020

Applies to:

Oracle Communications Unified Inventory Management - Version 7.4.1.0.0 and later
Information in this document applies to any platform.

Goal

Customer installed UIM 7.4.1.0.0 in ocal environment and would like to install and configure the compatible DS environment.

Need to clarify the following questions:

The referenced documents are:
Doc#1) Oracle® Communications Unified Inventory Management, Developer's Guide, Release 7.4.1, F25553-01, March 2020
Doc#2) Oracle® Communications Design Studio, Installation Guide, Release 7.4.1, F18562-01, June 2019

# Question 1 #################

Doc#1 says:
Software Versions for Developer Tools:
- Design Studio 7.4.1
- Eclipse 4.6 (Neon)

Doc#2 says:
Additional Software Requirements:
- Oracle Enterprise Pack for Eclipse Version 12.2.1.9 (or later), based on Eclipse Photon (4.8.0)

Q: Why two different Eclipse versions are needed?

# Question 2 ###################

Q: Is UIM 7.4.1.0.0 (latest) compatible with DS 7.4.1.2.0 (latest)?

# Question 3 ###################

Doc#1 says:
Software Versions for Developer Tools:
- Drools 7.31.0

Doc#1 says:
- Installing the Drools Eclipse Plug-ins
Copy the following URL and paste it into the Location field: http://downloads.jboss.org/drools/release/6.5.0.Final/org.drools.updatesite/

Q: What Drools version is supported? "7.31.0" or "6.5.0"
 

Solution

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Goal
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.