My Oracle Support Banner

Error "SQLite database failed to upgrade" When Attempting to Upgrade the Database After Upgrading the P6 Application (Doc ID 2769478.1)

Last updated on MAY 13, 2021

Applies to:

Primavera P6 Professional Project Management - Version 19.12 and later
Information in this document applies to any platform.

Symptoms

When logging in to P6 standalone for the first time after upgrading the application, the user is informed that the SQLite database version does not match the application version and prompts to upgrade the database.  After the user clicks Yes, the process immediately fails with the following error.

SQLite Database Failed to Upgrade.

 

The issue can be reproduced at will using the following steps:

  1. Upgrade P6 Professional to a newer version.
  2. Launch P6 and Login.
  3. A "Database Mismatch..." message is displayed; click OK.
  4. When prompted to upgrade the database, click OK again.
  5. View the reported error.

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.