My Oracle Support Banner

Oracle Mobile App (OMA) Does Not Work on iOS 15 (Doc ID 2815968.1)

Last updated on DECEMBER 22, 2021

Applies to:

Oracle Utilities Network Management System - Version 2.3.0.2.0 to 2.5.0.1.0 [Release 2.3 to 2.5]
Oracle Network Management for Utilities - DMS - Version 2.3.0.2.0 to 2.5.0.1.0 [Release 2.3 to 2.5]
Information in this document applies to any platform.

Details

If OMA is deployed to a iPad or iPhone running iOS 15.0.1, it fails to run.  You will see a message shown:

"<app name> Needs to Be Updated. The developer of this app needs to update it to work with this version of iOS."

Actions

Description

Upgraded iPad iOS from 14.8 to 15.0.1 once they upgraded iOS device to iOS 15.0.1 the OMA app no longer launch.
FIX: iOS 15 requires an enhanced signing capability available on MacOS BigSur (11.6) or newer and XCode 12.4 or higher. This is the only fix required for OMA1.

OMA2 has been updated to use cordova-ios platform version 6.2.0 and updated plugins to resolve true type font load issues and window spacing issues.

Migration

Please update the iOS development environment used to build the iOS version of OMA1 and OMA2 to BigSur (11.6) or newer and XCode to version 12.4 or higher
For OMA2, make changes to your OMA2 project as defined in the configuration section.


In order to use iOS, you will need to do the following:

OMAv1 and OMA2

This is required since the signing process on older MacOS versions is not compatible with iOS 15.

 

OMA2 only

There are product configuration changes that will be included in these patches

 
Release Bug
2.5.0.1.4 Bug - 33498773
2.5.0.0.6 Bug - 33498772
2.4.0.1.14 Bug - 33498771
2.3.0.2.22 Bug - 33439792

 

Configuration

1. Configuration:
Index: hybrid/config.xml
===================================================================



2:
Execute these commands from the OMA2 project directory:
# Remove packages to be updated:
       1.  ojet remove platform ios
       2.  ojet remove plugin cordova-plugin-inappbrowser
# update the iOS platform to 6.2.0
       3.  ojet add platform ios
# add in required plugins ignoring version or skip messages:
       4.  ojet add plugin cordova-plugin-inappbrowser@4.1.0
       5.  ojet add plugin cordova-plugin-wkwebview-engine
       6.  ojet add plugin cordova-plugin-wkwebview-file-xhr

 

Contacts

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Details
Actions
 OMAv1 and OMA2
 OMA2 only
 Configuration
Contacts
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.