RPM Related Failures- Error Downloading Packages- During Mammoth Upgrade on Oracle Big Data Appliance (BDA) (Doc ID 1596021.1)

Last updated on MARCH 29, 2016

Applies to:

Big Data Appliance Integrated Software - Version 2.0.1 and later
Linux x86-64

Symptoms

During any software upgrade on the Oracle Big Data Appliance (BDA) via the Mammoth utility (mammoth -p), RPM related errors like below are raised.  Note that the specifics can differ but RPM type errors will be raised.

ERROR: Puppet agent run on node bdanode had errors. List of errors follows

Stage[main]/Hadoop::Installcdhpkg/Package[webhcat]/ensure) change from 0.4.0+215-1.cdh4.2.0.p0.8.el5 to 0.5.0+9-1.cdh4.3.0.p0.12.el5 failed:
Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install webhcat' returned 1: This system is not registered with ULN. ULN support will be disabled.
Non-fatal POSTUN scriptlet failure in rpm package w error: %postun(webhcat-server-0.4.0+215-1.cdh4.2.0.p0.8.el5.noarch) scriptlet failed, exit status 3  
at /opt/oracle/BDAMammoth/puppet/modules/hadoop/manifests/installcdhpkg.pp:166
...
Stage[main]/Olh/Package[oraloader]/ensure) change from 2.1.0-2 to 2.2.0-h2 failed:
Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install oraloader' returned 1:   
Error Downloading Packages:   oraloader-2.2.0-h2.x86_64:
failure: RPMS/x86_64/oraloader-2.2.0-h2.x86_64.rpm from bda:
[Errno 256] No more mirrors to try.   at /opt/oracle/BDAMammoth/puppet/modules/olh/manifests/init.pp:9
...
Stage[main]/Olh/Package[orahdfs]/ensure) change from 2.1.0-1 to 2.2.0-1 failed:
Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install orahdfs' returned 1:   
Error Downloading Packages:   orahdfs-2.2.0-1.noarch: failure: RPMS/noarch/orahdfs-2.2.0-1.noarch.rpm from bda:
[Errno 256] No more mirrors to try.   at /opt/oracle/BDAMammoth/puppet/modules/olh/manifests/init.pp:15
...
Stage[main]//Node[default]/Package[orabalancer]/ensure) change from absent to present failed:
Execution of '/usr/bin/yum -d 0 -e 0 -y install orabalancer' returned 1:   
Error Downloading Packages:   orabalancer-1.0.1-h2.noarch:
failure: RPMS/noarch/orabalancer-1.0.1-h2.noarch.rpm from bda:
[Errno 256] No more mirrors to try.  
...
Finished catalog run in 28.59 seconds
Compiled catalog for bdanode.example.com in environment production in 0.19 seconds

 Another example of the output is:

Error [4164]: (//badnode1.example.com//Stage[main]/Miscsetup::Patch_fimage/Package[facter]/ensure)
change from 1.6.0-1.el5 to 1.6.1-0.1.rc4.el5 failed:
Could not update: Execution of '/usr/bin/yum -d 0 -e 0 -y install facter' returned 1:
This system is not registered with ULN.
ULN support will be disabled.   Error Downloading Packages:   facter-1.6.1-0.1.rc4.el5.noarch:
failure: RPMS/noarch/facter-1.6.1-0.1.rc4.el5.noarch.rpm from bda:
[Errno 256] No more mirrors to try. at /opt/oracle/BDAMammoth/puppet/modules/miscsetup/manifests/patch_fimage.pp:61

  

Note: "This system is not registered with ULN" can typically be ignored.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms