On Oracle Big Data Appliance Mammoth Upgrade Succeeds but Oracle Linux is Not Upgraded (Doc ID 2065520.1)

Last updated on SEPTEMBER 07, 2016

Applies to:

Big Data Appliance Integrated Software - Version 4.1.0 and later
Linux x86-64

Symptoms

When performing a Mammoth upgrade, upgrading the BDA is successful such that the kernel is upgraded and the cluster verification tests succeed. However Step 8 fails with errors indicating that the Oracle Linux (OL) packages  are not at the version expected for the upgraded release.

This note uses an example of upgrading from BDA V4.1 to BDA V4.2.

1. For example in the case of upgrading from BDA V4.1 to BDA V4.2, Step 8 reports that the Oracle Linux packages are not what is expected in BDA V4.2 but rather that they remain at the version supported in BDA V4.1.

Output looks like:

bdanode01: ERROR: Required package version bash-4.1.2-15.el6_5.2.x86_64 is not supported in release 4.2.0
bdanode01: ERROR: Required package version coreutils-8.4-31.0.1.el6_5.2.x86_64 is not supported in release 4.2.0
bdanode01: ERROR: Required package version dnsmasq-2.48-13.el6.x86_64 is not supported in release 4.2.0
bdanode01: ERROR: Required package version hal-0.5.14-11.el6.x86_64 is not supported in release 4.2.0
bdanode01: ERROR: Required package version iptables-1.4.7-11.0.1.el6.x86_64 is not supported in release 4.2.0
bdanode01: ERROR: Required package version krb5-libs-1.10.3-15.el6_5.1.x86_64 is not supported in release 4.2.0
bdanode01: ERROR: Required package version krb5-workstation-1.10.3-15.el6_5.1.x86_64 is not supported in release 4.2.0
bdanode01: ERROR: Required package version libstdc++-4.4.7-4.el6.x86_64 is not supported in release 4.2.0
bdanode01: ERROR: Required package version libstdc++-4.4.7-4.el6.i686 is not supported in release 4.2.0
bdanode01: ERROR: Required package version mdadm-3.2.6-7.el6_5.2.x86_64 is not supported in release 4.2.0
....

ERROR: Software checks failing on host bdanode01
...
ERROR: Software checks failing on host bdanode0n
ERROR: Big Data Appliance failed cluster health checks
...



2. Running 'imageinfo' shows everything is upgraded to the expected BDA V4.2 values except the Oracle Linux packages:

Output of 'dcli -C imageinfo' is like:

192.*.*.1: Big Data Appliance Image Info
192.*.*.1:
192.*.*.1: IMAGE_CREATION_DATE : Mon May 18 23:26:53 CEST 2015
192.*.*.1: IMAGE_LABEL : BDA_4.2.0_LINUX.X64_RELEASE
192.*.*.1: IMAGE_VERSION : 4.2.0
192.*.*.1: LINUX_VERSION : Oracle Linux Server release 6.5   <<<<
192.*.*.1: KERNEL_VERSION : 2.6.39-400.249.3.el6uek.x86_64
192.*.*.1: BDA_RPM_VERSION : bda-4.2.0-1.el6.x86_64
192.*.*.1: OFED_VERSION : OFED-IOV-1.5.5-2.0.0088
192.*.*.1: JDK_VERSION : jdk1.8.0_45-1.8.0_45-fcs.x86_64
192.*.*.1: HADOOP_VERSION : 2.6.0-cdh5.4.0
...


In the case of upgrade from BDA V4.1 to BDA V4.2 the Oracle Linux Server release should be 6.6 not OL 6.5 as above.

3. The 'rpm -qa' output shows the same behavior i.e. non-upgraded OL packages.

4. On Node 1 of the cluster the "post_upgrade_Script_<id>.out" files generated for each cluster node show errors indicating that the OL packages for BDA V4.2 did not get installed due to conflicts with package versions which do not typically reside on the BDA.

For example in the case here the "post_upgrade_Script_.out" files on Node 1, for each cluster node show that the OL packages were not upgraded due to conflicts with i686  package versions which do not reside on the BDA by default.

The errors in the example here show:

a) Multilib version problems:

  xorg-x11-apps-7.7-6.el6.x86_64 from bda
  xorg-x11-drv-evdev-2.8.2-4.el6.x86_64 from bda
  xorg-x11-drv-vesa-2.3.2-15.el6.x86_64 from bda
  xorg-x11-drv-void-1.4.0-23.el6.x86_64 from bda
  xorg-x11-server-Xorg-1.15.0-25.1.el6_6.x86_64 from bda
  xorg-x11-server-utils-7.7-2.el6.x86_64 from bda
Error: Multilib version problems found. This often means that the root
  cause is something else and multilib version checking is just
  pointing out that there is a problem. Eg.:

  1. You have an upgrade for libxcb which is missing some
  dependency that another package requires. Yum is trying to
  solve this by installing an older version of libxcb of the
  different architecture. If you exclude the bad architecture
  yum will tell you what the root cause is (which package
  requires what). You can try redoing the upgrade with
  --exclude libxcb.otherarch ... this should give you an error
  message showing the root cause of the problem.

  2. You have multiple architectures of libxcb installed, but
  yum can only see an upgrade for one of those arcitectures.
  If you don't want/need both architectures anymore then you
  can remove the one with the missing update and everything
  will work.

  3. You have duplicate versions of libxcb installed already.
  You can use "yum check" to get yum show these errors.

  ...you can also use --setopt=protected_multilib=false to remove
  this checking, however this is almost never the correct thing to
  do as something else is very likely to go wrong (often causing
  much more problems).


  Protected multilib versions: libxcb-1.9.1-2.el6.x86_64 != libxcb-1.8.1-1.el6.i686
Error: Protected multilib versions: libselinux-2.0.94-5.8.el6.x86_64 != libselinux-2.0.94-5.3.el6_4.1.i686
Error: Protected multilib versions: libselinux-devel-2.0.94-5.8.el6.x86_64 != libselinux-devel-2.0.94-5.3.el6_4.1.i686
Error: Protected multilib versions: elfutils-libelf-devel-0.158-3.2.el6.x86_64 != elfutils-libelf-devel-0.152-1.el6.i686
Error: Protected multilib versions: elfutils-libelf-0.158-3.2.el6.x86_64 != elfutils-libelf-0.152-1.el6.i686
You could try running: rpm -Va --nofiles --nodigest
Loaded plugins: aliases, changelog, downloadonly, filter-data, keys, list-data,
  : ps, security, verify
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package jdk1.8.0_45.x86_64 2000:1.8.0_45-fcs will be erased
--> Finished Dependency Resolution


and

b) Other errors due to i686 package conflicts:

Error: Package: e2fsprogs-devel-1.42.8-1.0.1.el6.i686 (@server)
  Requires: libcom_err-devel = 1.42.8-1.0.1.el6
  Removing: libcom_err-devel-1.42.8-1.0.1.el6.x86_64 (@anaconda-OracleLinuxServer-201311261449.x86_64/6.5)
  libcom_err-devel = 1.42.8-1.0.1.el6
  Updated By: libcom_err-devel-1.42.8-1.0.2.el6.x86_64 (bda)
  libcom_err-devel = 1.42.8-1.0.2.el6
Error: Package: e2fsprogs-devel-1.42.8-1.0.1.el6.i686 (@server)
  Requires: e2fsprogs-libs = 1.42.8-1.0.1.el6
  Removing: e2fsprogs-libs-1.42.8-1.0.1.el6.i686 (@anaconda-OracleLinuxServer-201311261449.x86_64/6.5)
  e2fsprogs-libs = 1.42.8-1.0.1.el6
  Updated By: e2fsprogs-libs-1.42.8-1.0.2.el6.i686 (bda)
  e2fsprogs-libs = 1.42.8-1.0.2.el6
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
error: Failed dependencies:
  libclntsh.so.11.1()(64bit) is needed by (installed) oracle-hmp-tools-biosconfig-2.3.0.0-1.el6.x86_64
  libclntsh.so.11.1()(64bit) is needed by (installed) oracle-hmp-tools-ubiosconfig-2.3.0.0-1.el6.x86_64
  libnnz11.so()(64bit) is needed by (installed) oracle-hmp-tools-biosconfig-2.3.0.0-1.el6.x86_64
  libnnz11.so()(64bit) is needed by (installed) oracle-hmp-tools-ubiosconfig-2.3.0.0-1.el6.x86_64
Loaded plugins: aliases, changelog, downloadonly, filter-data, keys, list-data,
  : ps, security, verify
Skipping filters plugin, no data
Setting up Install Process


Note: if upgrading to BDA V4.2 and the kernel is not upgraded, see: On Oracle Big Appliance CDH Cluster Upgrade, Linux Kernel is Not Updated (Doc ID 1982970.1).

It may also be the case that the rdma package is not upgraded as well.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms