After Upgrade to Mammoth 4.8.0 bdacheckcluster Raises "ERROR: Wrong Hadoop Parcel Version : 5.7.0"

(Doc ID 2346492.1)

Last updated on FEBRUARY 05, 2018

Applies to:

Big Data Appliance Integrated Software - Version 4.8.0 and later
Linux x86-64

Symptoms

Using an example of an upgrade to BDA V4.8.0, after upgrade bdacheckcluster raises the following on one BDA node:

ERROR: Wrong Hadoop parcel version : 5.7.0

Where the parcel version references the pre-upgrade CDH version not the upgraded CDH version.  

This can happen on any BDA upgrade as well.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms