My Oracle Support Banner

Upgrade to 12.2 fails for OWM component with "ORA-22814: attribute or element value is larger than specified in type" (Doc ID 2455411.1)

Last updated on APRIL 18, 2019

Applies to:

Workspace Manager - Version 11.2.0.4 to 12.2.0.1 [Release 11.2 to 12.2]
Information in this document applies to any platform.

Symptoms

Database upgrade to 12.2.0.1 fails when upgrading the Oracle Workspace Manager component with the following errors:

catupgrd0.log shows :

*** WARNING: ERRORS FOUND DURING UPGRADE ***

1. Evaluate the errors found in the upgrade logs
and determine the proper action.
2. Rerun the upgrade when the problem is resolved

REASON:
ERRORS FOUND: During Upgrade
FILENAME: /oracle/cfgtoollogs/dbua/upgrade2018-09-27_10-08-20-AM/DBA12T01/catupgrd0.log AT LINE NUMBER: 1679075
------------------------------------------------------
Identifier OWM 18-09-27 10:39:31
SCRIPT = [/oracle/product/12.2.0.1/dbhome_1/rdbms/admin/owmcvws.plb]
ERROR = [ORA-22814: attribute or element value is larger than specified in type]
STATEMENT = [create or replace view wmsys.wm$mw_versions_view_9i as
select version, modified_by, wmsys.ltUtil.wm$concat(cast(collect(workspace) as wmsys.wm$ident_tab_type)) seen_by
from (select vht.version, vht.workspace modified_by, mw.workspace
from wmsys.wm$mw_table mw, wmsys.wm$version_table vt, wmsys.wm$version_hierarchy_table vht
where mw.workspace = vt.workspace and
vt.anc_workspace = vht.workspace and
vht.version <= vt.anc_version
union all
select vht.version, vht.workspace modified_by, mw.workspace
from wmsys.wm$mw_table mw, wmsys.wm$version_hierarchy_table vht
where mw.workspace = vht.workspace
)
group by (version,modified_by)
WITH READ ONLY]

 

Component Current Version Elapsed Time
Name Status Number HH:MM:SS

Oracle Server                                         UPGRADED 12.2.0.1.0 00:13:33
JServer JAVA Virtual Machine                   UPGRADED 12.2.0.1.0 00:06:35
Oracle Real Application Clusters               UPGRADED 12.2.0.1.0 00:00:00
Oracle Workspace Manager
ORA-22814: attribute or element value is larger than specified in type
Oracle Workspace Manager                  INVALID 12.2.0.1.0 00:01:03
OLAP Analytic Workspace                        UPGRADED 12.2.0.1.0 00:00:20
Oracle OLAP API                                     UPGRADED 12.2.0.1.0 00:00:19
Oracle Label Security                              UPGRADED 12.2.0.1.0 00:00:10
Oracle XDK                                            UPGRADED 12.2.0.1.0 00:01:45
Oracle Text                                            UPGRADED 12.2.0.1.0 00:00:53
Oracle XML Database                              UPGRADED 12.2.0.1.0 00:02:16
Oracle Database Java Packages               UPGRADED 12.2.0.1.0 00:00:16
Oracle Multimedia                                  UPGRADED 12.2.0.1.0 00:02:32
Spatial                                                  UPGRADED 12.2.0.1.0 00:05:42
Oracle Database Vault                            UPGRADED 12.2.0.1.0 00:00:24

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.