My Oracle Support Banner

Datapatch precheck failed : Release update is BEING installed to PDB but is not installed in CDB$ROOT.This will cause a patch mismatch between this PDB and CDB$ROOT (Doc ID 2604940.1)

Last updated on NOVEMBER 28, 2019

Applies to:

Oracle Database - Enterprise Edition - Version 18.5.0.0.0 and later
Information in this document applies to any platform.

Symptoms

On : 18c, Patch Set Update - Security Patch Update


Datapatch precheck fails with message like below :

Error: prereq checks failed!
Release update 18.7.0.0.0 Release_Update 1906241920 is being installed to PDB but is not installed in CDB$ROOT.
This will cause a patch mismatch between this PDB and CDB$ROOT and prevent the PDB from opening. Please use the allow_pdb_mismatch option if this is really intended.

OR

Is successfully applied in CDB$ROOT, but is to be rolled back from PDB.
This will cause a patch mismatch between PDB and CDB$ROOT and prevent the PDB from opening unrestricted. Please use the allow_pdb_mismatch option if this is really intended.

OR

Is not successfully installed in CDB$ROOT but is to be applied to PDB.
This will cause a patch mismatch between PDB  and CDB$ROOT and prevent the PDB from opening unrestricted. Please use the allow_pdb_mismatch option if this is really intended.

 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.