My Oracle Support Banner

Database Upgrade From 19c to 21c failed with ORA-04061: existing state of package body "WMSYS.OWM_VSCRIPT_PKG" has been invalidated (Doc ID 2881078.1)

Last updated on JULY 13, 2022

Applies to:

Oracle Database - Enterprise Edition - Version 21.5 and later
Information in this document applies to any platform.

Symptoms

Database Upgrade from 19c to 21c using Autoupgrade failed with the below error reported in catupgrd_timestamp_instance_0.log log file.

...
begin
wmsys.owm_vscript_pkg.upgradeOWM(:old_owm_version_for_upgrade) ;
end;
/
ORA-04068: existing state of packages has been discarded
ORA-04061: existing state of package body "WMSYS.OWM_VSCRIPT_PKG" has been invalidated
ORA-04065: not executed, altered or dropped package body "WMSYS.OWM_VSCRIPT_PKG"
ORA-06508: PL/SQL: could not find program unit being called: "WMSYS.OWM_VSCRIPT_PKG"
ORA-06512: at line 2
...

 This issue only affects the Oracle Workspace Manager component.

Oracle Database Release 21 Post-Upgrade Status Tool 05-03-2022 21:27:0
Container Database: <db_name>I
[CON_ID: 4 => <pdb_name>]

Component Current Full Elapsed Time
Name Status Version HH:MM:SS

Oracle Server UPGRADED 21.5.0.0.0 00:38:24
JServer JAVA Virtual Machine UPGRADED 21.5.0.0.0 00:01:23
Oracle XDK UPGRADED 21.5.0.0.0 00:01:55
Oracle Database Java Packages UPGRADED 21.5.0.0.0 00:00:19
OLAP Analytic Workspace UPGRADED 21.5.0.0.0 00:00:29
Oracle Label Security UPGRADED 21.5.0.0.0 00:00:17
Oracle Database Vault UPGRADED 21.5.0.0.0 00:00:45
Oracle Text UPGRADED 21.5.0.0.0 00:00:42
Oracle Workspace Manager
ORA-04068: existing state of packages has been discarded ORA-04061: existing
state of package body "WMSYS.OWM_VSCRIPT_PKG" has been invalidated
ORA-04065: n
ot executed, altered or dropped package body "WMSYS.OWM_VSCRIPT_PKG"
ORA-06508:
PL/SQL: could not find program unit being called: "WMSYS.OWM_VSCRIPT_PKG"
ORA-06
512: at line 2

ORA-04061: existing state of package body "WMSYS.OWM_VSCRIPT_PKG" has been i
nvalidated
ORA-04065: not executed, altered or dropped package body "WMSYS.OWM_V
SCRIPT_PKG"
ORA-06508: PL/SQL: could not find program unit being called: "WMSYS.
OWM_VSCRIPT_PKG"
ORA-06512: at line 2

invalidated ORA-04065: not executed, altered or dropped package body "WMSYS.
OWM_VSCRIPT_PKG"
ORA-06508: PL/SQL: could not find program unit being called: "W
MSYS.OWM_VSCRIPT_PKG"
ORA-06512: at line 2

ORA-04065: not executed, altered or dropped package body "WMSYS.OWM_VSCRIPT_
PKG"
ORA-06508: PL/SQL: could not find program unit being called: "WMSYS.OWM_VSC
RIPT_PKG"
ORA-06512: at line 2

"WMSYS.OWM_VSCRIPT_PKG" ORA-06508: PL/SQL: could not find program unit being
called: "WMSYS.OWM_VSCRIPT_PKG"
ORA-06512: at line 2

ORA-06508: PL/SQL: could not find program unit being called: "WMSYS.OWM_VSCR
IPT_PKG"
ORA-06512: at line 2

"WMSYS.OWM_VSCRIPT_PKG" ORA-06512: at line 2

ORA-06512: at line 2
Oracle Workspace Manager INVALID 21.5.0.0.0 00:00:37  <<<<<<< Invalid component >>>>>>>
Oracle Real Application Clusters UPGRADED 21.5.0.0.0 00:00:01
Oracle XML Database UPGRADED 21.5.0.0.0 00:01:30
Oracle OLAP API UPGRADED 21.5.0.0.0 00:00:34
Datapatch 00:00:07
Final Actions 00:00:13
Post Upgrade 00:00:00

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.