My Oracle Support Banner

Upgrading BDA 4.13/4.14 to 5.2 Fails in Step 2 With "Package: rhnsd", "Requires: rhn-check", and i686 RPMs (Doc ID 2978390.1)

Last updated on NOVEMBER 26, 2023

Applies to:

Big Data Appliance Integrated Software - Version 4.13.0 and later
Linux x86-64

Symptoms

NOTE: In the examples that follow, user details, cluster names, hostnames, directory paths, filenames, etc. represent a fictitious sample (and are used to provide an illustrative example only). Any similarity to actual persons, or entities, living or dead, is purely coincidental and not intended in any manner. 

While upgrading from BDA 4.13/4.14 to BDA 5.2, Step 2 UpdateBaseImage fails.  The Mammoth output contains errors like the following:

3. The Mammoth step "UpdateBaseImage" is trying to update the package glibc-common, but cannot do so due to a conflict between the BDA 5.2 glibc-common x86_64 RPM and an existing glibc i686 RPM.

4. On the Mammoth node, the BDA repository does not contain the glibc i686 RPM. In this example, /opt/oracle/BDAMammoth/bdarepo/RPMS/i686 would not contain glibc-2.17-292.0.1.el7.i686.

glibc-2.17-292.0.1.el7.i686 is not one of the BDA 5.2 Mammoth packages.  This RPM is part of a custom third-party software installation.   

Changes

 N/A

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.