OCILOBREAD2 cannot Be Compiled in 32-Bit Installations. Error: "parse error before oraub8" (Doc ID 443830.1)

Last updated on DECEMBER 02, 2016

Applies to:

Oracle Server - Enterprise Edition - Version: 10.1.0.2 to 10.2.0.1 - Release: 10.1 to 10.2
HP-UX PA-RISC (64-bit)
This will affect php installations/configurations on HP-UX 64 bit, using oci libraries provided with Oracle Database versions: 10.1.0.2, 10.1.0.4, 10.2.0.1.

Symptoms

Configuring PHP with oci8 provided with 10.1.0.2, 10.1.0.4.0 or 10.2.0.1 database software (64 bit), on HP-UX 64bit.

Gmake version in the system is 32 bit.

When running the 'configure' command to setup PHP, on compiling time the following error is displayed (this is stack from a php 4.4.7 config):

#gmake
[...]
gcc -Iext/oci8/ -I/opt/php-4.4.7/ext/oci8/ -DPHP_ATOM_INC -I/opt/php-4.4.7/include
-I/opt/php-4.4.7/main
-I/opt/php-4.4.7 -I/mrs-t_u01/app/oracle/product/1010/rdbms/public
-I/mrs-t_u01/app/oracle/product/1010/
rdbms/demo -I/mrs-t_u01/app/oracle/product/1010/plsql/public -I/opt/php-4.4.7/ext/xml/expat
-I/opt/php-4.
4.7/TSRM -I/opt/php-4.4.7/Zend -D_XOPEN_SOURCE_EXTENDED -g -O2 -c
/opt/php-4.4.7/ext/oci8/oci8.c -o ex
t/oci8/oci8.o && echo > ext/oci8/oci8.lo
In file included from /opt/php-4.4.7/ext/oci8/oci8.c:50:
/opt/php-4.4.7/ext/oci8/php_oci8_int.h:343: error: parse error before "oraub8"
gmake:  *** [ext/oci8/oci8.lo] Error 1

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms