SDO_3GL PACKAGE BODY INVALID AFTER APPLYING 10.2.0.4 (Doc ID 564939.1)

Last updated on NOVEMBER 07, 2012

Applies to:

Oracle Spatial - Version 10.2.0.4 and later
Information in this document applies to any platform.
***Checked for relevance on 07-Nov-2012***


Symptoms

The package body MDSYS.SDO_3GL is invalid after database upgrade to 10.2.0.4

SQL> alter package SDO_3GL compile body;



Warning: Package Body altered with compilation errors.

SQL> show errors

Errors for PACKAGE BODY SDO_3GL:


LINE/COL ERROR
-------- -----------------------------------------------------------------
1433/7 PL/SQL: Statement ignored
1433/28 PLS-00302: component 'CONVERT_DISTANCE' must be declared
1447/9 PL/SQL: Statement ignored
1447/26 PLS-00302: component 'CONVERT_DISTANCE' must be declared
1471/7 PL/SQL: Statement ignored
1471/24 PLS-00302: component 'EXPAND_MULTI_POINT' must be declared

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms