BI Publisher Desktop 10 Installation Ends With 'Please make sure Windows Installer version 2.0 or greater is installed' On Windows 7 (Doc ID 1140651.1)

Last updated on JUNE 22, 2016

Applies to:

BI Publisher (formerly XML Publisher) - Version 10.1.3.4.1 to 10.1.3.4.2 [Release 10.1]
Information in this document applies to any platform.

Symptoms

Installation of BI Publisher Desktop Tools 10.1.3.4.1 fails on Windows 7.

ERROR :

The installer ends with the following error message:

Please make sure Windows Installer version 2.0 or greater is installed.
You can download Windows Installer from: (url).
 

However, Windows Installer version 5.0 is available in the system.

Steps to reproduce:

1. Launch the installer BIPublisherDesktop.exe
2. The User Account Control dialog for Windows 7 requests additional privileges for the installer; answer "Yes".
3. Select language English in the InstallShield Wizard dialog, click "Next >"
4. The error message is shown.
5. Click "Ok"; the installer terminates.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms