Unable to Play Oracle Learning Management Elearning Course After SSL Certificate Was Upgraded On Load Balancer From SHA-1 to SHA-2 SSL Certificate (Doc ID 2237198.1)

Last updated on FEBRUARY 23, 2017

Applies to:

Oracle Learning Management - Version 12.1 HRMS RUP9 and later
Information in this document applies to any platform.

Symptoms

On : 12.1 HRMS RUP9 version, Learner Component

Unable to play elearning course

When users attempt to play any and all elearning courses they get the error:- "An error has occurred:Error initializing communication with LMSPress 'OK' to view debug information .

Customer is not able to access any courses after upgrading to SHA 2 SSL certificate.


SETUP:
---------------------

* E-Business mid-tier is non-SSL however entry point for EBS is SSL enabled at load balancer.
* Issue with unable to play elearning course started after SSL certificate was upgraded on load balancer from SHA-1 to SHA-2 SSL certificate.

* Weblogic OLM Content Server 10.3.6 is non SSL enabled.
* Using Javascript (JS) Scorm Adapters






ERROR
-----------------------
ERROR - LMS Initialize Failed

20:Tue Feb 14 09:29:09 UTC 2017 - GetQueryStringValue Element 'ShowDebug' Not Found, Returning: empty string
21:Tue Feb 14 09:29:09 UTC 2017 - strStandAlone= strShowInteractiveDebug=
22:Tue Feb 14 09:29:09 UTC 2017 - Standard From Configuration File - SCORM
23:Tue Feb 14 09:29:09 UTC 2017 - Using Standard From Configuration File - SCORM
24:Tue Feb 14 09:29:09 UTC 2017 - In LMSStandardAPI strStandard=SCORM
25:Tue Feb 14 09:29:09 UTC 2017 - Calling Standard Initialize
26:Tue Feb 14 09:29:09 UTC 2017 - In SCORM_Initialize
27:Tue Feb 14 09:29:09 UTC 2017 - In SCORM_ClearErrorInfo
28:Tue Feb 14 09:29:09 UTC 2017 - Grabbing API
29:Tue Feb 14 09:29:09 UTC 2017 - In SCORM_GrabAPI
30:Tue Feb 14 09:29:09 UTC 2017 - Searching with improved ADL algorithm
31:Tue Feb 14 09:29:09 UTC 2017 - In SCORM_GetAPI
32:Tue Feb 14 09:29:09 UTC 2017 - SCORM_GetAPI, searching parent




Weblogic 10.1.3.6 Oracle Learning Management Content Server Admin Server Log Error :
The loading of the trusted certificate list raised a certificate parsing exception PKIX: Unsupported OID in the AlgorithmIdentifier object: 1.2.840.113549.1.1.11.>


STEPS
-----------------------
The issue can be reproduced at will with the following steps:
1. Launch course via LMS Player



BUSINESS IMPACT
-----------------------
The issue has the following business impact: 'Customer is not able to access any courses after upgrading to SHA 2 SSL certificate

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms