My Oracle Support Banner

"ORA-42804: The operation can disclose rows protected by VPD policy" Error Generated Logging Into OTM 6.4.3 After Moving the Database to 19C (Doc ID 2695259.1)

Last updated on JULY 28, 2020

Applies to:

Oracle Transportation Management - Version 6.4.3 to 6.4.3 [Release 6.4]
Information in this document applies to any platform.

Symptoms

The following error may be generated in the < OTM Home >/logs/glog.exception.log when logging into OTM for the first time after upgrading the OTM Database to 19C with the latest Roll Up ( RU ) installed.

<YYYY-MM-DD HH:MM:SS.xxx 0 Error Exception [000041] [SQL_STATEMENT] update gl_user set last_login_date = TO_DATE(?,'YYYY-MM-DD HH24:MI:SS'), unsuccessful_login_attempts = 0 where gl_user_gid=? or username=?;  [YYYY-MM-DD HH:MM:SS, <GL_USER_GID>, <Username>]
   java.sql.SQLException: ORA-42804: The operation can disclose rows protected by VPD policy.


java.sql.SQLException: ORA-42804: The operation can disclose rows protected by VPD policy.

Changes

Installing the latest RU patch available for 19C Database.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.