[ PCA 2.3.1+ ] Re-provisioning a compute node fails with " failed (1): stderr: mount.ocfs2: Transport endpoint is not connected while mounting /dev/mapper/XX on /poolfsmnt/XX "

(Doc ID 2316872.1)

Last updated on OCTOBER 13, 2017

Applies to:

Private Cloud Appliance - Version 2.3.1 and later
Linux x86-64

Symptoms

On Oracle Private Cloud Appliance, when attempting to re-provision a compute node, it fails with the following kind of error recorded in the /var/log/ovca.log :

[2017-10-12 07:23:16 1690002] INFO (tenant_group:421) Attempting to add ovcacn09r1 to the Tenant Group Rack1_ServerPool
[2017-10-12 07:23:16 1690002] INFO (ovm:103) Calling ovmwsh script [add_server_to_tenant_group.py] with args ('--tenantgroup=Rack1_ServerPool', '--server=ovcacn09r1')
[2017-10-12 07:25:27 478708] DEBUG (service:114) call start: register_discovered_node('00:10:e0:b6:34:97', '192.168.4.106')
[2017-10-12 07:25:27 478708] DEBUG (service:116) call complete: register_discovered_node
[2017-10-12 07:25:27 478715] DEBUG (service:114) call start: register_discovered_node('00:10:e0:b6:34:97', '192.168.4.106')
[2017-10-12 07:25:27 478715] DEBUG (service:116) call complete: register_discovered_node
[2017-10-12 07:26:45 1690002] WARNING (ovm:142) ovmwsh script finished with error: 1
STDOUT: Looking for [server] [ovcacn09r1]
Looking for [tenant group] [Rack1_ServerPool]
Adding the server [ovcacn09r1] to the tenant group [Rack1_ServerPool]
Failed to adding the server [ovcacn09r1] to the tenant group [Rack1_ServerPool]: Error: Job failed. Job description: Add Server: ovcacn09r1 to Server Pool: Rack1_ServerPool.
error: OVMAPI_4010E Attempt to send command: configure_server_for_cluster to server: ovcacn09r1 failed. OVMAPI_4004E Sync command failed on server: 192.168.140.7. Command: configure_server_for_cluster,

Server error: org.apache.xmlrpc.XmlRpcException: <type 'exceptions.RuntimeError'>:Command: ['mount', '/dev/mapper/3600144f0db3ea6550000595f57d10003', '/poolfsmnt/0004fb00000500006b68ac8a5f72ab2b'] failed (1): stderr: mount.ocfs2: Transport endpoint is not connected while mounting /dev/mapper/3600144f0db3ea6550000595f57d10003 on /poolfsmnt/0004fb00000500006b68ac8a5f72ab2b. Check 'dmesg' for more information on this error.

 

When opening the Oracle VM Manager Graphical User Interface, and editing the server pool, the Time Out for Cluster is set to 120.

Changes

 Recent re-discovery of the tenant group through the Oracle VM Graphical User Interface.

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms