My Oracle Support Banner

Upgrade System 'yum update' Failed With 3rd Party Repositories Dependency Errors (Doc ID 2335824.1)

Last updated on AUGUST 04, 2018

Applies to:

Linux OS - Version Oracle Linux 6.0 and later
Linux x86-64


Upgrade system with command 'yum update'  in some situation throws errors regarding 3rd Party repositories dependencies, like:

Error: Package: pam-1.1.1-24.0.1.el6.x86_64 (@anaconda-OracleLinuxServer-201703241427.x86_64/6.9)
Removing: db4-4.7.25-22.el6.x86_64 (@anaconda-OracleLinuxServer-201703241427.x86_64/6.9)
Obsoleted By: libdb4-4.8.30-13.el7.x86_64 (epel) <--------------------------- EPEL 3RD PARTY REPOSITORY
Not found
Available: db4-4.7.25-16.el6.x86_64 (public_ol6_ga_base)
Available: db4-4.7.25-17.el6.x86_64 (public_ol6_latest)
Available: db4-4.7.25-18.el6_4.x86_64 (public_ol6_latest)
Available: db4-4.7.25-19.el6_6.x86_64 (public_ol6_latest)
Available: db4-4.7.25-20.el6_7.x86_64 (public_ol6_latest)
Available: db4-4.7.25-20.el6_8.1.x86_64 (public_ol6_latest)
Error: Package: libtomcrypt-1.17-25.el7.x86_64 (epel)<--------------------------- EPEL 3RD PARTY REPOSITORY
Error: Package: libdb4-cxx-4.8.30-13.el7.x86_64 (epel)<--------------------------- EPEL 3RD PARTY REPOSITORY
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

In this example it is from EPEL, but it can be from REMI, IUS and others not from Oracle public repositories.




To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.