My Oracle Support Banner

Spacewalk 2.7: Package download via spacewalk-reposync fails with "[Errno 14] HTTP Error 407 - Proxy Authentication Required." (Doc ID 2422769.1)

Last updated on AUGUST 04, 2018

Applies to:

Linux OS - Version Oracle Linux 7.5 to Oracle Linux 7.5 [Release OL7U5]
Linux x86-64

Symptoms

Package download via spacewalk-reposync fails with "[Errno 14] HTTP Error 407 - Proxy Authentication Required." although proxy with Authentication is correctly configured in /etc/rhn/rhn.conf.

Below errors in /var/log/rhn/reposync/<repo_name>.log

2018/04/26 15:16:01 +02:00 Sync of channel started.

2018/04/26 15:16:01 +02:00 Repo URL: http://yum.oracle.com/repo/OracleLinux/OL7/spacewalk27/client/x86_64/

2018/04/26 15:16:07 +02:00 Packages in repo: 45

2018/04/26 15:16:07 +02:00 Packages already synced: 1

2018/04/26 15:16:07 +02:00 Packages to sync: 26

2018/04/26 15:16:07 +02:00 New packages to download: 26

2018/04/26 15:16:07 +02:00 ERROR: Download failed: http://yum.oracle.com/repo/OracleLinux/OL7/spacewalk27/client/x86_64/getPackage/koan-2.8.1-2.el7.noarch.rpm - [Errno 14] HTTP Error 407 - Proxy Authentication Required.

2018/04/26 15:16:07 +02:00 1/26 : koan-2.8.1-2.el7.noarch.rpm (failed)

2018/04/26 15:16:07 +02:00 ERROR: Download failed: http://yum.oracle.com/repo/OracleLinux/OL7/spacewalk27/client/x86_64/getPackage/rhn-custom-info-5.4.37-1.0.1.el7.noarch.rpm - [Errno 14] HTTP Error 407 - Proxy Authentication Required.

2018/04/26 15:16:07 +02:00 2/26 : rhn-custom-info-5.4.37-1.0.1.el7.noarch.rpm (failed)

2018/04/26 15:16:07 +02:00 ERROR: Download failed: http://yum.oracle.com/repo/OracleLinux/OL7/spacewalk27/client/x86_64/getPackage/osa-common-5.11.89-1.el7.noarch.rpm - [Errno 14] HTTP Error 407 - Proxy Authentication Required.

2018/04/26 15:16:07 +02:00 ERROR: Download failed: http://yum.oracle.com/repo/OracleLinux/OL7/spacewalk27/client/x86_64/getPackage/rhn-setup-2.7.16-1.0.1.el7.noarch.rpm - [Errno 14] HTTP Error 407 - Proxy Authentication Required.

2018/04/26 15:16:07 +02:00 3/26 : osa-common-5.11.89-1.el7.noarch.rpm (failed)

2018/04/26 15:16:07 +02:00 4/26 : rhn-setup-2.7.16-1.0.1.el7.noarch.rpm (failed)

2018/04/26 15:16:07 +02:00 ERROR: Download failed: http://yum.oracle.com/repo/OracleLinux/OL7/spacewalk27/client/x86_64/getPackage/osad-5.11.89-1.el7.noarch.rpm - [Errno 14] HTTP Error 407 - Proxy Authentication Required.

2018/04/26 15:16:07 +02:00 5/26 : osad-5.11.89-1.el7.noarch.rpm (failed)

2018/04/26 15:16:07 +02:00 ERROR: Download failed: http://yum.oracle.com/repo/OracleLinux/OL7/spacewalk27/client/x86_64/getPackage/rhn-check-2.7.16-1.0.1.el7.noarch.rpm - [Errno 14] HTTP Error 407 - Proxy Authentication Required.

2018/04/26 15:16:07 +02:00 6/26 : rhn-check-2.7.16-1.0.1.el7.noarch.rpm (failed)

Changes

 NA

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.