My Oracle Support Banner

QLA2xxx Firmware Cannot Update to version 2019.12.02 or higher (Doc ID 2657955.1)

Last updated on MAY 19, 2020

Applies to:

Linux OS - Version Oracle Linux 7.7 with Unbreakable Enterprise Kernel [4.14.35] and later
Linux x86-64
Linux x86

Symptoms

The system will upgrade to HPe HBA firmware version 2019.12.02 due to critical issue but that neccesarry to driver 10.01.00.52.07.6-k1 or higher.

Fixed the following :

In extremely rare cases, the following QLogic Fibre Channel (FC) Host Bus Adapters (HBAs), SN1100Q, SN1600Q and SN1610Q may cause the host Operating System (OS) to stop. Subsequent OS reboot may reveal some filesystem data is unavailable or inconsistent. Out of an abundance of caution, HPE updated the Firmware/BIOS/UEFI (Boot Image) packages for these adapters to eliminate possible exposure to this extremely rare but critical issue.

In Linux, the following error messages from the adapter driver will be seen :

"MPI Heartbeat stop. Chip reset needed. MB0[%xh] MB1[%xh] MB2[%xh] MB3[%xh]\n" "MPI Heartbeat stop. FW dump needed\n" If ql2xextended_error_logging is enabled, then users may also see the message "Invalid status handle (0x%x).\n

A HPE Server nunning Oracle Linux 7 with the UEK kernel needs its QLogic HBA firmware upgraded to a version newer than 2019/12/02 due to a critical issue. However the firmware update needs the kernel's qla2xx driver to be 10.01.00.52.07.6-k1 or higher, and attempting the upgrade with the UEK kernel fails.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.