My Oracle Support Banner

E-BI/XMLP: String Field Leading Zeroes Do Not Appear When Report Is Run To Excel (Doc ID 1073241.1)

Last updated on DECEMBER 07, 2019

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.48 and later
Information in this document applies to any platform.
*** Currency Checked December 2013 ***
*** Currency Checked September 2015 ***

Symptoms

BI Publisher, (XML Publisher), reports that have fields based on String values in the database, where the numbers have leading zeros, when run to Excel output the leading zeroes are not shown in the resulting Excel output.

For a value such as: "0001000", it appears as "100".

When the same report is run to .HTM, .PDF or .RTF, the leading zeroes are correctly displayed.

By following these steps the issue can be reproduced:

1. Log in into PIA.

2. Go to Reporting Tools > Query > Query Manager to create a new Query.

3. Create a Query on record containing a VARCHAR field with prefix zeroes (for example, PS_DEPT_TBL record containing DEPTID field).

4. Save the new Query.

5. Go to Reporting Tools > XML Publisher > Data Source to create a new Data Source.

6. Create a new Data Source using the newly created Query.

7. Click on "Generate" link to generate the sample XML Data File.

8. Click on "Generate" link to generate the XSD schema file.

9. Create a simple RTF template for XML Publisher and run it to XLS.

10. DEPTID values like "000100" are shown as "100" (numeric).

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.