My Oracle Support Banner

E-WL: Frequently Asked Questions about Upgrading WebLogic 10.3.x (for PeopleTools 8.51-8.53) to a Newer Maintenance Pack (MP), Patch Level, and/or a Newer Java/JRockit Patch Level (Doc ID 1389918.1)

Last updated on DECEMBER 10, 2019

Applies to:

PeopleSoft Enterprise PT PeopleTools - Version 8.51 to 8.53 [Release 8.4]
Information in this document applies to any platform.

Purpose

This document answers frequently asked questions regarding:

  1. Steps to Upgrading WebLogic to a newer maintenance pack and patch level
  2. Questions about Upgrading Java patch level for your WebLogic Install.
  3. Details on how to locate/download/install newer WebLogic Maintenance Packs, Patches and Java Patches


This document is specifically for PeopleTools 8.51, 8.52 and 8.53 environments which are using WebLogic 10.3.x.

Questions and Answers

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Purpose
Questions and Answers
 How can I tell what WebLogic Maintenance Pack/Patch#  that I'm currently using?
 How can I tell what Java Patch# that I'm currently using?
 What are the steps to get current on the latest WebLogic version and patch level?   What is the difference between Maintenance Packs and Patches?
 What are the steps for Upgrading WebLogic 10.3.x to the latest Maintenance Pack, Patch Level and Java Patch Level?
 Do I need to re-install the WebLogic PIA(s) after completing a WebLogic Upgrade?
 How can I validate that the WebLogic upgrade was successful?
 Do all PeopleTools 8.5x Environments use the same WebLogic Version and Java Version? And can I upgrade my existing PeopleTools Environment to a newer Weblogic Version (eg WebLogic 10.3 to WebLogic 12c) or a Newer Java Version (eg JDK 6 to JDK 7)?
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.