My Oracle Support Banner

When Tools Client Is Up and Running, The Installer For Tools Client Patchset/Update Keeps Running Without Warning. (Doc ID 2509669.1)

Last updated on NOVEMBER 11, 2019

Applies to:

Siebel CRM - Version 15.6 [IP2015] and later
Information in this document applies to any platform.

Symptoms

Before the installer for Siebel Tools Client patchset/update is started, target Siebel Tools Client should be stopped. Occasionally customer may not realize Tools Client is still running while the installer is started.

 

ACTUAL BEHAVIOR
---------------

The installer does not show any error or warning even if Tools client is still running. However it actually fails to replace files. As a result, Tools Client cannot restart with the following error.

Error: versions of installed components do not match (wanted version: 15.0.0.0, actual version:15.6.0.0 ENU)

** Actual version can be different. The same error occurs as of Update 19.1.

 

EXPECTED BEHAVIOR 
---------------

Installer should detect Tools Client is running. Then it should either give the warning and exit, or stop the running Tools Client then keep running for the installation.

 

STEPS TO REPRODUCE
--------------------------------------------------------------------------------

1) Start Tools Client, in this scenario 15.0

2) Apply patchset/Update. In this scenario 15.6.

3) Installation finishes without any error.

4) Stop Siebel Tools Client then restart. It fails with the error above. 

-------------------------------------------------------------------------------- 

Changes

 

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.