My Oracle Support Banner

eMail Response Stop Pulling Emails From Mail Box With Error "javax.mail.MessagingException: No appropriate protocol (protocol is disabled or cipher suites are inappropriate)" (Doc ID 2821336.1)

Last updated on NOVEMBER 29, 2021

Applies to:

Siebel CRM - Version 8.1.1.11 [IP2013] and later
Information in this document applies to any platform.

Symptoms

After upgrade one of the Siebel environments to Siebel CRM 21.9, the Siebel Server running CommInboundRcvr stopped pulling emails from the email box.

The same is working on other environments which were also update to Siebel CRM 21.9 Update, so the version does not seems to be relevant.

The setup of eMail Response was based on ALERT: How To Upgrade To JRE 64-bit support for Siebel IMAP and POP3 Driver for Email Response; Replaces 32-bit Driver From Siebel 21.3 and later (Doc ID 2761440.1) on all environments.

The following error can be observed on new mail.log



The issue can be reproduced at will in one of the Siebel Enterprise environment with the following steps:

  1. In of the the environment where Siebel Enterprise has been update to Siebel CRM  21.9 Update

  2. Setup Siebel eMail Response new 64 bit driver as per Doc ID 2761440.1


  3. Restart the Siebel Server running Communications Inbound Receiver component

  4. Check the new mail.log and IMAPSMTP_<CommInboundRcvr PID>_x_x_xxxx_xxxx.log, the Siebel driver is not able to connect to the IMAP Server showing the error above.

Please notice that there are other environment with same configuration working fine.

Other scenarios that could lead to this error:

A) Customer updating to Siebel CRM 21.11 or higher, since Siebel CRM bundled JRE is using JRE 1.8.0_291

B) Customer still using Siebel CRM 21.3 and previously which update the JRE used on EMRJavaSubsys Profile parameter JVM DLL Name

Changes

Siebel CRM updated to 21.11 or later OR for old Siebel CRM 21.3 or previous versions update the JRE used by EMRJavaSubsys Profile parameter JVM DLL Name OR update Siebel CRM 17.0-21.10 bundled JRE which is not supported.

Cause

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Symptoms
Changes
Cause
Solution
References


My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.