Solaris Cluster 4.x System Panic During Solaris Cluster Update to 4.1 SRU 1 to SRU 5 (Doc ID 1637438.1)

Last updated on MAY 01, 2017

Applies to:

Solaris Cluster - Version OSC 4.0 to OSC 4.1 [Release 4.0 to 4.1]
Solaris Cluster Geographic Edition - Version OSC 4.0 to OSC 4.1 [Release 4.0 to 4.1]
Oracle Solaris on SPARC (64-bit)
Oracle Solaris on x86-64 (64-bit)

Symptoms

The system might panic due to "BAD TRAP" during boots after the upgrade from Solaris 11.0 to 11.1 and Solaris Cluster 4.0 to 4.1.
The panics are intermittent  even on the same machine and might not occur all times you reboot after upgrade.

The stack trace reported in the message files after the panic message shall report the following function names: 

 


Changes

Solaris Cluster 4.0 (including SRUs) is not subject to this problem. The key change leading to the panic is the upgrade of Solaris Cluster to 4.1 series and in particular to SC4.1 or SC4.1 SRU 1 to SRU 5.
The command "pkg update" do normally update all installed software installed including both Solaris and Solaris Cluster, therefore any unconditional update might trigger the issue unless the pkg publisher for Solaris Cluster  do refer to SRUs which contain the fix.

 

Cause

Sign In with your My Oracle Support account

Don't have a My Oracle Support account? Click to get started

My Oracle Support provides customers with access to over a
Million Knowledge Articles and hundreds of Community platforms