My Oracle Support Banner

Oracle HSM: Release 6.1-04 Release is Now Available (Doc ID 2566094.1)

Last updated on SEPTEMBER 02, 2020

Applies to:

Oracle Hierarchical Storage Manager (HSM) and StorageTek QFS Software - Version 6.1.4 and later
Information in this document applies to any platform.

Details

The 6.1-04 release has now been superseded by the Oracle HSM (SAM-QFS) 6.1-05 release (build id 6.1.59), available on MOS (My Oracle Support), as of August 12, 2020.   Reference Document 2700396.1 for details.

 

The Oracle HSM (SAM-QFS) 6.1-04 release (build id 6.1.52) is now available out on MOS (My Oracle Support), as of July 21, 2019.

For 'best practices' prior and during an HSM (SAM-QFS) upgrade, reference Document 1538209.1

New Features in the 6.1-04 Release:

* 27091610 cloud fail-safe encryption
Ensure all file data archived or migrated to the Oracle OCI Classic Cloud
is encrypted with user controlled AES keys. See the samfsck(1M) -e
option for more details.

* 28279074 add media migration move copy support
Updated media migration with migrate move_copy option to support moving
one copy from source media to destination media. Using move_copy will
leave the source volume non-empty if multiple copies are present on the
volume, and only one copy is migrated.

* 26921661 Add support to HSM for Quantum Scalar i3 and i6 Tape Libraries
Quantum Scalar i3 and i6 tape libraries are now supported.

* 24521073 RFE: Oracle HSM : Upgrade sideband DB to work with MySQL 5.7
The sideband database was modified to work with MySQL 5.7.

* 28270207 Support Solaris 11.4 with Oracle HSM
* 21614014 Need to update devfsadm plugins to 64 bit for Solaris 11.4
Oracle HSM now supports Solaris 11.4 for server and client.

* 28578816 Add support for Oracle Linux 6.10 and 7.5
Oracle HSM supports now supports clients running on Oracle Linux 6.10
and all version of 7 up to 7.5. Support for Oracle Linux 5 and 6.0-6.9
have been removed.

These versions of Solaris and Oracle Linux have the changes made
for the "Spectre and Meltdown" issues.

* 29449073 Remove HSM graphical user interface
The graphical user interface (also known as the file system manager or
fsmgr) has been retired. There are significant security issues in the
underlying framework used by this portion of the product that cannot be
addressed. Removal of this functionality addresses the following
issues:
 29286333 CVE-2018-11784: APACHE TOMCAT TO 9.0.12, 8.5.34, 7.0.91
 28998186 CVE-2016-1000031: APACHE COMMONS FILEUPLOAD UPGRADE TO 1.3.3
 28143311 CVE-2018-8013: APACHE BATIK UPGRADE TO 1.10 OR LATER
 26934592 CVE-2017-12617: TOMCAT TO 7.0.82, 8.0.47, 8.5.23, 9.0.0
 22807360 CVE-2015-7501: APACHE COMMONS COLLECTIONS TO 3.2.2, 4.1

A complete listing of all the 6.1.X bugfixes can be found in the "README.txt" of the patch download bundle.

For details on the previous HSM 6.1-03 patch release, see Document 2328823.1.

For details on the HSM 6.1 Base release, see Document 2124212.1.

 

Actions

To download the HSM 6.1-04 release:

  1. Sign in to My Oracle Support (MOS).
  2. Click on the "Patches & Updates" tab near the top of the window.
  3. In the Patch Search pane, click on "Product or Family(Advanced Search)."
  4. In the Product field, type "qfs" or "hsm" and then choose 'Oracle Hierarchical Storage Manager (HSM) and StorageTek QFS Software'.
  5. In the Release field pulldown, select either 'Oracle Hierarchical Storage Manager (HSM) 6.1.4.0.0' for HSM or 'StorageTek QFS Software 6.1' for the QFS packages.
  6. Close the release pulldown window and click on the Search button.
  7. It should return the following two choices:

    30051925 ORACLE HIERARCHICAL STORAGE MANAGER 6.1 PATCH 4 (Patch)
    30051926 STORAGETEK QFS SOFTWARE 6.1 PATCH 4 (Patch)

  8. Choose 'Download' to download one of those packages.
  9. After uncompressing that file, there will be iso images for Sparc and x64, as well as Linux client os

 

Note: With the introduction of Solaris 11.4, a different build/package is provided for Solaris 11.4 over Solaris 11.[0-3]. It is important to install the proper package. If using S11.4, please navigate to the "S11.4" (SVR4 packages) or "S11.4_ips" (IPS) directory and install from there. This is particularly important if upgrading from S11.3 to S11.4. Oracle HSM must be removed and the Solaris 11.4 version of Oracle HSM installed.

For assistance with upgrading to the 6.1-04 release:


After installation, this release will report itself with a build id of '6.1.52'.

Documentation:

The HSM 6.1-04 Release Notes can be found within the downloaded zip file, in a file titled "README.txt".

 

Contacts

To view full details, sign in with your My Oracle Support account.

Don't have a My Oracle Support account? Click to get started!


In this Document
Details
 New Features in the 6.1-04 Release:
Actions
 To download the HSM 6.1-04 release:
 For assistance with upgrading to the 6.1-04 release:
 Documentation:
Contacts
References

My Oracle Support provides customers with access to over a million knowledge articles and a vibrant support community of peers and Oracle experts.